Home > Software > Data-Warehouse > Informatica
Interview Questions   Tutorials   Discussions   Programs   

Informatica - How to run the batch using pmcmd command?

asked marvit September 20, 2014 08:04 AM  

How to run the batch using pmcmd command?


1 Answers

answered By vishnoiprem   0  
Using Command task in the workflow
Step 1: Check if you have PMCMD available.
If you have informatica installed on your system that doesn’t mean you can execute this utility also, Use below command to find out this utility availability for your informatica installation. If not, Talk to your admin to check that your organization license has this utility in it or not. 

find . -name “PMCMD” –print , Command need to be executed at INFA application  root directory.

Step 2: If PMCMD is available.

  Check if execute access is there for all. User group and others should have execute access to this utility.

Step 3: Configure SHLIB_PATH environment variable.

Bottom line, To run this utility, you got to configure the SHLIB_PATH environment variable to include below directory (Path may differ for your setup).


Configuring shlib_path variable will enable you to run this utility from your UNIX ID in a particular UNIX environment.

You need to execute below two commands at command prompt to configure shlib_path variable.

SHLIB_PATH=$PATH:/appl/inform/Informatica/ 9.0.1/server/bin


Now your setup is ready, You can use syntax given in next step to  run start workflow with this utility.

Step 4:  Syntax : PMCMD Start Workflow

pmcmd startworkflow


–pv PASSWORD_TEST  # See comments for more info on Uname/Password.





For easy understanding I have kept every pmcmd startworkflow  parameter attributes in new line. You need to remove newline character and keep only one space before each parameter. At last your command will look like one shown in below picture.
   add comment

Your answer

Join with account you already have



Ready to start your tutorial with us? That's great! Send us an email and we will get back to you as soon as possible!